Products
2,507 Brands 483 Categories All Departments

Two dots when setting up an EOTECH??

Post a reply


Enter the code exactly as it appears. All letters are case insensitive.
Smilies
:D :) :( :o :shock: :? 8) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :wink: :!: :?: :idea: :arrow: :| :mrgreen:
BBCode is ON
[img] is OFF
[flash] is OFF
[url] is ON
Smilies are ON
Topic review
   

Expand view Topic review: Two dots when setting up an EOTECH??

Re: Two dots when setting up an EOTECH??

Post by Trevor_B on Mon Oct 03, 2011 10:06 am

your actually not doing anything wrong. Due to EOTech sights being true holographic sights the reticle will appear to move when your head position is changed. when sighting in make sure you have a good and proper cheek weld. that should keep the reticle centered. as your head position changes the reticle appears to move but you should still stay on target. One of the nice features of a true holographic sight.

Two dots when setting up an EOTECH??

Post by subsix on Mon Sep 26, 2011 6:00 pm

I'm new to holosights. Just bought a used EOTech XPS2 and have never owned a '[link=http://www.opticsplanet.com/red-dot-scopes.html]red dot' sight[/link] before. Sighting it in seems like it ought to be pretty straight forward, by dialing the MOA circle in using the elevation and windage screws on the right side. However, I can't seem to get the circle in the center of the site picture. If i offset my head left, I can see a circle on the far right, outside the sight picture. Likewise, if I offset my head right, I can see a second circle outside the sight picture on the far left. What am I doing wrong?? Thanks for any guidance.

Cheers,

Top